VMware® Workstation 8.0.3 – Fehler bei der Deinstallation (The MSI “ failed)

Nachdem ich nun schon über Jahre hinweg mit der VMware Workstation arbeite und nie wirklich Probleme hatte, stand ich neulich kurz vor einem Nervenzusammenbruch.

Seit einiger Zeit ist die VMware Workstation 9 im Handel und es war für mich klar, dass ich ein Upgrade durchführen würde. Eigentlich reine Routine, aber diesmal der Auftakt zu einer schlaflosen Nacht. Es folgt eine kurze  (selbstbemitleidende) Schilderung der Ereignisse:

Während der Installation, bzw. des Upgrade Versuchs unter Windows 7 64x Ultimate, kam die Meldung, dass die alte Version der VMware® Workstation zuvor deinstalliert werden müsse. Logisch. Leider schlug die Deinstallation mit der Meldung The MSI “ failed fehl. Nervig, aber so etwas passiert eben hin und wieder. Also ein weiterer Versuch über Programme und Funktionen. Leider mit der gleichen Fehlermeldung. Daraufhin das Tool „VMware Install Cleaner“ besorgt, als Admin ausgeführt und positive Meldung erhalten. Nur merkwürdiger Weise blieb das Problem weiterhin bestehen. Workstation 9 lässt sich nicht installieren, solange die Vorgänger Version nicht vollständigentfernt wurde. Würg!!

Weitere verzweifelte Versuche unter Zuhilfenahme von diversen Tools wie CCleaner oder Revo Uninstaller scheiterten kläglich. Manuelles Aufräumen der Registry käme einer Sisyphusarbeit gleich und war somit auch keine vernünftige Option. Also am besten die Workstation 8 komplett neu installieren um sie anschließend sauber mit einem Uninstaller zu entfernen. Aber falsch gedacht. Eine Neuinstallation der Workstation 8 schlug ebenfalls mit der gleichen Fehlermeldung fehl. Kurioser Weise ließ sich die Workstation 8 aber immer noch starten. Jedoch bei dem Versuch eine der VMs zu starten kam eine Fehlermeldung, die zur Neuinstallation der Workstation aufforderte. Zum Verrücktwerden.

Wie auch immer, letztendlich gibt es doch eine Lösung, die zumindest bei mir zum Erfolg geführt hat. Eigentlich ganz simpel. Startet man die Installation der Workstation 8 über die Windows Konsole (cmd.exe), dann funktioniert das Ganze problemlos. Die Konsole sollte mit Adminrechten gestartet werden. Die Befehlszeile sieht dann folgendermaßen aus:

VMware-workstation-full-8.0.3-*.exe /z  „action“=“install“

Logischerweise den Dateiname anpassen.

Wieso dieser Fehler überhaupt auftrat kann ich noch immer nicht nachvollziehen. Ich würde mich jedoch über jeden Hinweis sehr freuen, wenn jemand ähnliche Erfahrungen gemacht hat.

© Torsten Merz 2012


ALL-INKL.COM - Webhosting Server Hosting Domain Provider

besserdampfen53506ef335bd8